Symptom
Delivery Status is showing as 'In Process' in the General tab of a Sales Order that has a Product Line Item with Delivery Status as 'Finished' and a Service Line Item with Delivery Status as 'Not started' due to a reason for rejection maintained on the item level.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders Work Center.
- Go to the Sales Order View.
- In the search field, search for the Sales Order ID ABC (ABC represents the Sales Order ID).
- Open and select View All.
- Navigate to the Items tab.
A Product Line Item has the Delivery Status as 'Finished/ xx Each' and Invoice Status as 'Not Started'.
Service Line Item that was canceled has the Service Status as 'Not Relevant', Delivery Status 'Not Started' and Invoice Status as 'Not Relevant'.
- Go back to the General tab.
- The Delivery Status is 'In Process'.
Cause
When a Service Line Item is canceled with a reason for rejection maintained, the Delivery Status for that Line Item will be as 'Not Started' and the overall Delivery Status in the General tab will be 'In Process'.
To complete the sales document the Product Line Item has to be invoiced, therefore it will change the Sales Order Status to 'Completed' but the Delivery Status will be 'In Process'.
This behavior occurs because the Delivery/Fulfillment Status of Service Line Item is "Not Started", hence this will keep the overall Delivery Status of the Sales Order as 'In Process' even after the document is completed.
Resolution
This is the Standard System Behavior for this scenario.
See Also
The following KBA will provide further information regarding the cancelation of a Service Line Item in a Sales Order document:
2911400 - How To Cancel Sales Order With a Service Line Item
Keywords
not started, service item, cancel, canceled, product delivery base, service line item, in process, finished , KBA , AP-SLO-SO , Sales Order , How To