Symptom
You are trying to generate output e-mail for a Remittance Advice Outbound but the status ends in Error.
In Error Details you see the message "Invalid recipient address username@domain.extension".
You do not know where the system is getting this e-mail address from.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Payment Management work center.
- Go to Payment Monitor view.
- Search for the relevant ID.
- Enter it.
- Go to Output History tab.
- You can see the error message "Invalid recipient address (username@domain.extension)".
Cause
Under the Payee's Communication details, there is a rule maintained for Remittance Advice Outbound that defines that this e-mail address is used.
Resolution
To check which e-mail address is maintained under the Remittance Advice Outbound rule and change it, follow below steps:
- Go to Payment Management work center.
- Go to Payment Monitor view.
- Search for the relevant ID.
- Enter it.
- In General tab, search for the Payee.
- Enter it.
- Click View All.
- Go to Communication tab.
- Click Collaboration.
- You can see a rule maintained for Remittance Advice Outbound with the e-mail address.
- Make the necessary change to the correct e-mail you wish to use.
Keywords
Invalid recipient address, Ongeldig ontvangeradres, Outgoing Bank Transfer not sent, Remittance Advice e-mail not sent, Remittance Advice Output error , KBA , AP-RC-OUT , Output Management , Problem