SAP Knowledge Base Article - Public

3349666 - Output e-mail for Remittance Advice Outbound fails with error message "Invalid recipient address"

Symptom

You are trying to generate output e-mail for a Remittance Advice Outbound but the status ends in Error. 

In Error Details you see the message "Invalid recipient address username@domain.extension". 

You do not know where the system is getting this e-mail address from.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Payment Management work center.
  2. Go to Payment Monitor view.
  3. Search for the relevant ID.
  4. Enter it.
  5. Go to Output History tab.
  6. You can see the error message "Invalid recipient address (username@domain.extension)".

Cause

Under the Payee's Communication details, there is a rule maintained for Remittance Advice Outbound that defines that this e-mail address is used.

Resolution

To check which e-mail address is maintained under the Remittance Advice Outbound rule and change it, follow below steps:

  1. Go to Payment Management work center.
  2. Go to Payment Monitor view.
  3. Search for the relevant ID.
  4. Enter it.
  5. In General tab, search for the Payee.
  6. Enter it.
  7. Click View All.
  8. Go to Communication tab.
  9. Click Collaboration.
  10. You can see a rule maintained for Remittance Advice Outbound with the e-mail address.
  11. Make the necessary change to the correct e-mail you wish to use.

Keywords

Invalid recipient address, Ongeldig ontvangeradres, Outgoing Bank Transfer not sent, Remittance Advice e-mail not sent, Remittance Advice Output error , KBA , AP-RC-OUT , Output Management , Problem

Product

SAP Business ByDesign all versions