SAP Knowledge Base Article - Public

3349681 - SAP Marketing Cloud - Business Partner Deletion

Symptom

You are using SOAP based integration between SAP Cloud for Customer and SAP Marketing Cloud. Contacts and Accounts are replicated as Business Partner (BuPa), followed by the SMC Interaction Contact (IC) object. Using the Marketing Contact Deletion jobs deletes the SMC IC object but not the BuPa. This KBA explains how to delete the BuPa object as well.

Environment

  • SAP Marketing Cloud Edition

Reproducing the Issue

  1. Import contacts from SAP Cloud for Customer to SAP Marketing Cloud using the SOAP interface.
  2. Delete the contacts using the application job 'Contacts: Flag Contacts for Deletion' followed by 'Contacts: Delete Flagged Contacts'
  3. Observe that the SMC IC object is deleted, but the BuPa is still existing in SMC - a new import of the contact fails with the error:
    "Error: Business partner [BuPa ID] already exists"

Cause

This is the current application design. The application jobs 'Contacts: Flag Contacts for Deletion' and 'Contacts: Delete Flagged Contacts' are designed to delete the SMC IC object only. For the BuPa deletion follow the steps documented below.

Resolution

Please refer to the following help page:

Blocking, Unblocking and Deletion of Business Partner, Customer and Supplier Master Data

This explains how to block, unblock or delete business partners. After the residence period is completed and data is blocked, it either remains in the database or is stored in an archive. If the blocked data remains in the database, the data manager can delete the blocked business partner, customer and supplier master data from the database using the corresponding archiving objects.

For more details please refer to the following sources:

To destroy data from archives, you can use the ILM Data Destruction app so that the data can no longer be retrieved. For more information about the ILM Data Destruction app, please refer to the following help page:

ILM Data Destruction

!Important!

SMC does not support tenant refresh!

After deletion/blocking the business partner, the same business partner cannot be replicated to SMC anymore. 

The right approach to delete business partners needs to be triggered from the source system. The deletion in SAP Cloud for Customer should be transferred to SAP Marketing Cloud with using the 'End of Purpose' flag.

See Also

Business Partner, delete, archive

Keywords

KBA , CEC-MKT-DM-IC , Interaction Contact , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions