SAP Knowledge Base Article - Public

3349792 - Phone number field is not mandatory in "Refer Friend to a Job" using Internal Career Site powered by CSB - RCM/RMK

Symptom

When referring a friend to a job when having Internal Career Site Powered by Career Site Builder the cellPhone field is not mandatory, even though it is mandatory in the template.

Environment

  • SAP SuccessFactors Recruiting Management
  • SAP SuccessFactors Recruiting Marketing

Cause

Employee Referral in Internal Career Site Powered by Career Site Powered uses CandidateLight entity via API, and if in there cellPhone is set as required="false" (you can verify that through the OData API Data Dictionary), then it won't be required in the referral screen. This is an expected behavior.

Resolution

The field can be made required by doing the following changes:

  1. Validate the CandidateLight entity for phone number required attribute in the OData API Data Dictionary
  2. Go to Admin Center > Manage Duplicate Candidates
  3. Go to Advanced Options tab, and tick the option "Check country/region code and phone number" checkbox to be checked
  4. Perform an OData API Metadata Refresh, and validate the required in refer a friend flow

Keywords

internal, career, site, csb, site, builder, rmk, referral, refer, job, requisition, candidate, applicant, cellphone, cell, phone, number, home. , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem

Product

SAP SuccessFactors Recruiting all versions