SAP Knowledge Base Article - Public

3349833 - Error received when completing I-9 Section 2 - Onboarding

Symptom

US I9 Section 2 completion error: 

  • 'The information provided for Document Number for Social Security Card Document Type does not match our records.'

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login to the instance as the manager/responsible user for US I9 Section 2
  2. Fill in the details for List B and C Documents.
  3. Submit
  4. Error is received.

Cause

There's a mismatch between the SSN card listed in Document C and the SSN provided in Section 1.

Resolution

This is the reason for the error in Section 2 of the I-9 form.

  • To fix this, the manager or responsible user needs to initiate a correction for Section 1, so that the updated SSN will be reflected in the I-9.
  • Following this, Section 1 needs to be re-signed, and then Section 2 can be completed.

Keywords

I-9, Section 2, List C, SSN, Document Type, I9 Section 2 error, OBX, ONB2, Onboarding , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem

Product

SAP SuccessFactors Onboarding 2305