Symptom
User finished the exam in the content with score 100 but "User Credit Given" column value is NO while "User Finished" column is YES on the Online Item Status Report.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
1. Learning Administration > Report > Online Item Status Report
2. Filter Item and run report
3. There are inconsistent records that "User Credit Given" as NO while "User Finished" as YES
Cause
There is issue with the content where it is overriding the completion if user attempt the quiz again within the same session.
The user completed the content by answering all questions correctly - which sent the completion details to LMS and completion is recorded.
However, if user did not close the content window, attempted another question in the same session and then closed the content window, the content will send score again for just the last attempted question to LMS and a lesson status "Failed".
Due to the overriding data sent from content, report is displaying data with the User Credit Given as N and User Finished as Y.
***
Further explanation on these two columns:
User Finished column corresponds to whether the course is finished or not, since in the first attempt the user already completed all the questions with score 100, user finished is set to Y.
User credit given is based on the score sent by the content to the backend, in the second attempt user must have not answered all questions and closed the window, which sent the score for that few questions (e.g. 10/100) and set the credit given as N.
Since the content is not attempted completely, the user finished flag that was saved as Y previously remains the same. Only User credit given is set to N.
Resolution
Since the data issue is caused by content, please ask your content vendor to resolve the issue.
See Also
Keywords
data inconsistency, completion, LMS , KBA , LOD-SF-LMS-REP , Reporting Data , Problem