Symptom
When creating outbound delivery referring Sales Order, the field "Country of Origin" under International Trade tab in item level is not retrieved from Material Master data.
Environment
SAP S/4HANA Cloud Public Edition
Cause
The Addresses of Supplier and Ship-To-Party are in the same Country, it's not relevant for Import/Export.
Automatic population of the Country & Region of Origin for Deliveries will only take place in case the delivery is relevant for Import/Export.
Resolution
Extend the data model with a custom field (e.g. YY1_COUNTRYORIG) on the delivery item entity (I_DeliveryDocumentItem). This custom field can be filled inside the available Cloud BAdI LE_SHP_MODIFY_ITEM.
Information from the material in the delivery item can be selected from CDS view I_Product.
If this is considered a valid use case, a feature request can be created through https://influence.sap.com/sap/ino/#. For more information, refer to SAP Note 2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product.
See Also
- https://influence.sap.com/sap/ino/#
- 2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product
Keywords
Country of Origin, Region of Origin, Material Master, Outbound Delivery, Outbound Delivery Item, Custom Field, I_DeliveryDocumentItem, LE_SHP_MODIFY_ITEM, International Trade , KBA , LE-SHP-DL-2CL , Delivery Processing (Public Cloud) , Problem
SAP Knowledge Base Article - Public