Symptom
It is required to capture the exact longitude and latitude for Clock in Clock Out in Mobile Device
Environment
- SAP SuccessFactors Time Tracking - Clock in Clock out
Reproducing the Issue
1. Go to Employee's Time Sheet (Mobile device)
2. Select any date within the Time Sheet week
3. Click on Clock Time and record a Clock in/Clock out
4. Address will show
5. Captured location and the actual location of user are not same.
Cause
SuccessFactors both Android and iOS app requests permission to access device's approximate location and not precise one.
Message in Android:
Message in iOS:
Resolution
Both iOS and Android control for location accuracy to the end user; hence, it is not possible for SuccessFactors to capture the accurate location but only the approximate location.
Android - https://developer.android.com/codelabs/approximate-location#0
iOS - https://support.apple.com/en-ca/guide/personal-safety/ips9bf20ad2f/web
That is why the captured location and the actual location of the user are not the same.
Also, please pay attention that even after Location Capture is enabled as per Creating Clock In Clock Out Groups, the access to device's approximate location must be granted to allow SF Mobile App to really access the approximate location information on Mobile devices. Otherwise, no location would be captured for the time events, even though Location Capture has been enabled in the Clock In Clock Out Group setting.
See Also
Keywords
location, location capture, longitude, latitude, mobile, approximate location, punch, clock, precise, access, ttr, tracking, times, clock-in, clock-out, punch-in, punch-out , KBA , LOD-SF-TTR-CIO , Clock In/ Clock Out , LOD-SF-EC-TMS-MOB , Mobile , How To
Product
Attachments
Pasted image.png |
Android_Location_Permission.png |