SAP Knowledge Base Article - Public

3350786 - Notes in Appointments and Follow-Up Opportunity have a different input format

Symptom

When user attempts to input text in the Appointment's Notes field, the content does not display with an additional line break (empty line space) however when a follow-up Opportunity is created, an additional empty line break is displayed after each line.

Environment

SAP Cloud for Customer

SAP Business ByDesign

Reproducing the Issue

  1. Go to Activities Work center
  2. Go to Appointments view
  3. Select the ID XXXX (Here XXXX refers to an appointment ID)
  4. Click on Follow-Up and Select Opportunity from the dropdown
  5. Enter all the required details and save the Opportunity


In appointment ID XXXX, the input text in the Notes field is displayed without an empty line (no spacing). If user creates a follow up Opportunity, there is now an empty line in the Notes field. 

Cause

This could be due to the formatting issue.

The Notes field in the Appointment is using formatted text. It can be verified by seeing all the formatting buttons at the top of the Notes input field in Appointment. The Note field in the Opportunity does not support formatted text. Therefore, only the converted text is visible in the opportunity.
The original text in the Appointment is formatted in such a way that every single line is a separate paragraph. During the conversion into plain text, paragraphs are separated by two-line breaks. Consequently, each line is separated by an empty space.

Resolution

This is the expected system behavior. 

Keywords

Notes, Appointment, Opportunity, Line break, Empty Line Space, Follow-Up , KBA , AP-RC-OUT , Output Management , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer core applications all versions