Symptom
Not the exact longitude and latitude was captured for Clock in Clock Out in Mobile Device
Environment
- SAP SuccessFactors Time Tracking all versions
- SAP SuccessFactors Clock in Clock out
Reproducing the Issue
1. Go to Employee's Time Sheet (Mobile device)
2. Select any date within the Time Sheet week
3. Click on Clock Time and record a Clock in/Clock out
4. Address will show
5. Captured location and the actual location of user are not same.
Cause
SuccessFactors both Android and iOS app requests permission to access device's approximate location and not precise one.
Message in Android:
Message in iOS:
Resolution
SF app doesn't capture precise location of the user but captures approximate location only.
That's the reason of captured location and the actual location of user are not same.
SF only captures approximate location and will not get precise one due to legal implications.
Improving location requires more permissions like scanning Wifi networks, Bluetooth, etc.
It will have many legal implications for our app, so we only have an approximate location now.
See Also
SAP Help page of Location Capture in Clock In Clock Out:
https://help.sap.com/docs/SAP_SUCCESSFACTORS_RELEASE_INFORMATION/8e0d540f96474717bbf18df51e54e522/825202e300234502951902f659b5670e.html?locale=en-US
Keywords
location, location capture, longitude, latitude, mobile, approximate location , KBA , LOD-SF-EC-TMS-MOB , Mobile , How To