Symptom
In OData API Audit Log, you notice that there are only recent records, such as API requests within the past few days or weeks.
Any records older than that time period are no longer available / cannot be searched in OData API Audit Log.
You would like to know whether it's possible for Audit Log to save the records for longer time, or how to retrieve those missing records.
Environment
SAP SuccessFactors HXM Suite
Cause
There is a maximum log count for OData API Audit Log. This number varies from 10,000 to 500,000 depending on the Provisioning setting.
When the limit is reached, older records are purged and you can no longer find them.
Resolution
To increase the maximum log count, you could go to Provisioning "API Settings & Tools" -> "OData API Audit Log Setting" -> Change the maximum count
Also, it's not possible to retrieve purged records. You need to download and save them before they are purged.
See Also
SAP SuccessFactors API Reference Guide (OData V2) - Enabling API Audit Logs
Keywords
SF, SuccessFactors, Success Factors, delete, range, remove, view, Purge, payload, request, API call, maximum count , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem