SAP Knowledge Base Article - Public

3351352 - System freezes while adding help links to Company-Specific Content

Symptom

When the user attempts to configure help links in Company-Specific Content, the system freezes for a longer period of time and shows the error "Enter a valid url".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Login to Business ByDesign system
  2. Navigate to Help Center
  3. Under Company-Specific Help select Add Company-Specific Help or Add Company-Specific Help: All Screens
    • To add company-specific content to a particular screen, click Add Company-Specific Content.
    • To add company-specific content to all screens, click Add Company-Specific Content for all Screens.
  4. To add a new link, click on New and choose Link.
  5. Enter URL, Name, Duration, Description and Click on OK

The system freezes and displays an error message "Enter a valid url"

Cause

Issue is due to the special character ":" (like as :b) present in the URL link,  which is against the standard http URL validation.  

For example, 

  1. Navigate to Help Center in Business ByDesign
  2. Under Company-Specific Help select Add Company-Specific Help or Add Company-Specific Help: All Screen
  3. To add a new link, click on New and choose Link
  4. Paste the link copied from the Sharepoint

For example, the copied Sharepoint link is as below and contains unsupported special character ":b"

abcdefg/:b:/r/sites/ByD-/hijklmn/opqrs.pdf?csf=1&web=1&e=IJFHk4 

Note: The above mentioned URL is not specific to any customer, it is only for reference to analyse how the special characters could be displayed in the copied url link.

Resolution

According to standard SharePoint, the direct file contains special characters like :b, :x, :w, and :f, that are used to identify the file type. In order to add the help links in Company-Specific content use the file path by following the below steps.

  1. Login to Business ByDesign system
  2. Navigate to Help Center
  3. Under Company-Specific Help select Add Company-Specific Help or Add Company-Specific Help: All Screens
  4. Choose New and Select File
  5. Choose Browse and select the File path
  6. Enter Name, Duration, Description and Click on OK, the system adds the link successfully.

See Also

1843098 - How to add Company Specific Help Document in the Help Center in SAP Business ByDesign (ByD)

3293632 - Not Able to Add Company-Specific Help in format "mailto"

Keywords

Company-Specific, Help links, System Freeze, URL, Special characters , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , Problem

Product

SAP Business ByDesign all versions