Symptom
You have SAP Marketing Cloud integrated with SAP Cloud for Customer. You plan to perform a Tenant Refresh in Cloud for Customer as documented in the following KBA:
2751824 - How to Request Tenant Refresh for SAP Cloud for Customer
Please consider that the Tenant Refresh is not supported in SAP Marketing Cloud.
Environment
- SAP Marketing Cloud Edition
Reproducing the Issue
-
Perform a Tenant Refresh in Cloud in Cloud for Customer
-
Delete BuPa and IC objects in SAP Marketing Cloud
- Create new Contacts or Accounts in Cloud for Customer and observe that importing those Business Partners to Marketing Cloud fail with the error:
"Error: Business partner [BuPa ID] already exists"
Cause
SAP Marketing Cloud does not support Tenant/Client Refresh. There is no way to fully delete the Business Partner in SAP Marketing Cloud - when a business partner has been deleted or archived (e.g. by ILM tools), the used Business Partner IDs cannot be used again in this system.
This restriction is documented in the following KBAs:
Resolution
In case the Tenant Refresh in SAP Cloud for Customer already took place the only workaround available is to use new BuPa IDs, so to make sure that the BuPa ID was not yet used in Cloud for Customer. SAP Marketing Cloud won't accept the same BuPa ID again, but will accept new BuPa IDs only.
See Also
Cloud for Customer; Marketing Cloud, C4C, SMC, Tenant Refresh
Keywords
KBA , CEC-MKT-DM-IC , Interaction Contact , Problem