Symptom
You are using the report Time Accounts: Monthly from Business Analytics, and you notice that a time account assigned to an employee is missing in the report.
You also see that the time account does not appear in the Time Account Balances tab of the employee profile.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Analytics work center.
- Enter the Design Reports view.
- Search and open the report Time Accounts: Monthly.
- Enter a search criteria (for example, the employee ID).
- Click on the button Apply.
Here you can see the time accounts assigned to the employee, however some accounts are missing.
Cause
The Bookable From and Bookable To fields in the time account configuration are missing.
Resolution
In order to check and solve the issue, please follow the below steps:
- Go to Business Configuration work center.
- Enter the Overview view.
- Search for the activity Time Accounts - XYZ (where XYZ represents the relevant country name).
- Open the sub activity Maintain Time Account Types.
- Search for the missing account and select it.
- Under the Details section on the bottom of the screen, maintain data for Bookable From and Bookable To.
Keywords
HCMTLMU02, Time Profile, Bookable , KBA , SRD-HR-TLM , Time and Labour Management , How To