Symptom
Receiving error:
"SAML 2.0 error.
Error Code: 100004
Error message: Identity Provided with EntityId 'IDP information' on tenant 'Tenant information' is not enabled.
Log Reference ID: "
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
Create a new IDP.
Cause
If there is and IDP already created and a new one is created for the same URL, system will create new URL with a different postfix that cannot be changed.
If this is a new and unique IDP the possible cause is the IDP not being activated.
Resolution
If If this is a new and unique IDP it should be activated according to the Help article: https://help.sap.com/docs/SAP_CPQ/f80fbcd4f1c74232839c30ce26886f07/1a0011cf555c4888bb3ab53efd065851.html?version=latest
If there is and IDP already created and a new one is created, delete the previous IDP and create the new one.
See Also
Check the following Help articles for common error codes and Federation troubleshooting:
- Error Codes for Federated Sigle Sign-On: https://help.sap.com/docs/SAP_CPQ/f80fbcd4f1c74232839c30ce26886f07/5b4e062d82f84281a3477eeb5a867180.html?version=latest
- Federation Troubleshooting: https://help.sap.com/docs/SAP_CPQ/665a9ee212394653a84a393035090802/1388b7d005914567a090ff1668279213.html?version=latest
Keywords
CPQ, Federation, SSO, Single Sign On, IDP, Settings, Error code, SAML, 2.0 , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Known Error