Symptom
- You are using the Agent Desktop/Service Agent Console in SAP Service Cloud
- You business requires implementing a role-based access control to restrict chat activity creation for specific users and enable it for others.
- You would like to understand the best options to achieve such requirement.
Environment
- SAP Cloud for Customers
- SAP Cloud for Service
- Agent Console Add-On for SAP Service Cloud
Cause
Restricting Chat Activities is exclusively possible through the Employee Org Unit Assignment due to the system's inherent logic.
Resolution
- SAP recommends implementing access restrictions based on the Employee ORG Assignment to meet the chat activity restriction requirements using ACL (Access Control List).
- It is recommended to start with a few users to test with, and once all is working, then expand the number of users required.
- For example, assume the Business Role configured is "BusinessRole_A_ACL.":
- Ensure the "COD_CHAT_WCVIEW" is defined for "COD_ACTIVITIES" for said Business Role
- Go to Administrator -> General Settings -> Business Roles (see "Manage Authorizations" for more details)
- Open the Business Role (e.g. "BusinessRole_A_ACL") and assign users to this Business role.
- Navigate to "Work Center and View Assignments" -> Search for Work Center ID = COD_ACTIVITIES and Work Center/View Name = Chats.
- Ensure the "Assigned to" checkbox is selected and save changes.
- Navigate under ‘Access Restrictions’ -> ‘Chats’ (COD_ACTIVITIES)
- Set the restriction as "1016 – Employee, Territory, Account, Sales Data"; the 'Read Access' and 'Write Access' columns must be in the 'Restricted' state.
- Move down to the "Detailed Restrictions" and use the 'Employees' Access Group ID to set restrictions versus the 'Sales Organization' (see "Assign and Edit Access Rights").
- Save the changes and perform a test with a few users. Once all works as expected, add more users to the Business Role as needed.
See Also
Keywords
ACL, Chat, Access, Rights, Restrictions , KBA , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2305