SAP Knowledge Base Article - Public

3352435 - Unable to see Record Working Time when proxy as Employee

Symptom

“Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.“

  • When proxy as employee , Record Working Time is not seen , however the Admin is able to see the Record Working time

Environment

  •  SAP SuccessFactors Employee Central - Time Sheet

Reproducing the Issue

  1. Proxy as an employee , and click on View My Time sheet
  2. Record Working Time is not seen
  3. Proxy as an Admin , and click on View Time sheet for the same employee above 
  4. Record Working Time is seen

Cause

  • Enabled in employee self-service scenario  is set to NO for all attendance Time Types , the employee is not able to Record Working Time

Resolution

  1. Go to Manage Data--> Time Profile
  2. Select the Time Profile 
  3. Click on Take Action -->Make Correction
  4. Select all Attendance Time Types and click on Details
  5. Set the Enabled in employee self-service scenario  as YES
  6. Save 

Keywords

Time Sheet , Employee Timesheet, Record , working Time , time type , not available, absent, not visible , KBA , LOD-SF-EC-TMS , Time Sheet , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors Time Tracking all versions