SAP Knowledge Base Article - Public

3352445 - "Unable to parse oauth token... statusCode: 401" error when connecting to an external system - Integration Center

Symptom

You have created OAuth Configurations for external system in Security Center to be used in your Integration Center job.

When executing the Integration Center job it is failing & you see the below errors in the Event Logs:

The same OAuth credentials are working without issue & successfully authenticate against the external system when tested in an external REST client (e.g. Google Postman).

Environment

  • SAP SuccessFactors HCM Suite 
    • Integration Center
    • Security Center
      • OAuth Configurations
        
      

Cause

This is a known limitation of the Microsoft package/code used in the OAuth implementation for Security Center where their token endpoint is unable to parse OAuth token when there are special characters being used in the client_secret

Resolution

Please use a client_secret which does not contain special characters.

See Also

Github reference: https://github.com/MicrosoftDocs/azure-docs/issues/30467

Keywords

Unable to parse oauth token,  Failed to get access token, ServiceApplicationException, Security Center, OAuth, destination settings, Client Secret, 401, ServiceApplicationException, access, URL, token , KBA , LOD-SF-INT-INC-SEC , Security Center , LOD-SF-INT-INC , Integration Center , Problem

Product

SAP SuccessFactors HCM Suite all versions