Symptom
On creating a contact via SSI Add-in and when viewed in C4C, the e-mail address gets stored under personal addresses section instead of E-mail field located in the header.
Environment
SAP Cloud for Customer/Outlook (Server side integration)
Reproducing the Issue
1. Create a contact from outlook add-in using server side integration
2. Provide all relevant details including e-mail and save the contact
3. In C4C go to Customer->contacts
4. Search for the newly created contact you will notice the email address being saved in the personal addresses section
Cause
The fields email, phone, function, department, in the contact person TI header UI in C4C are relationship dependent fields. If No account is entered in outlook no relationship in C4C can be created.
Resolution
You will have to maintain an account in the time of contact creation in order for it to appear in the E-mail field of the header.
Keywords
Server side integration, E-mail, contact , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To