Symptom
When attempting to merge Individual Customers, you get the error message "Merge not possible: Business Partner XXXXX (XXXX) has multiple roles assigned.''
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Individual Accounts and open customer XXXX
2. Click on 'Duplicate check' and select any of the records in the result list with similarity 100%
3. Click 'Merge'. The error is shown
Cause
The Record is an Individual Customer but the Business Partner is also Contact Person for Account.
Resolution
Merging of Business Partners with multiple roles like in this example (Individual Customer & Contact Person) is not supported.
This is Expected Behaviour.
Keywords
Merge, Individual Customer, Business Partner, Duplicate Check , KBA , LOD-LE-BP-MRG , Business Partner Merge , Problem