SAP Knowledge Base Article - Public

3352559 - Email address (customer information) is getting changed when reloading quote in CPQ-C4C integration

Symptom

This article explains how CPQ system evaluates customer information coming from C4C and how to avoid issues of customer information getting changed when switching tabs between CPQ & C4C.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

1. Login in to C4C
2. Go to opportunity : 12345 (test)
3. Create a new quote in opportunity
4. Check email address in customer info (say, firstname.lastname@company.com)

5. Now, check in C4C in the same opportunity, go to 'Involved Parties' tab. The email address is same 'firstname.lastname@company.com'
6. Now, come back to CPQ >  Customer info tab or reload the Quote. You will see that the email has changed from previous firstname.lastname@company.com to '12345.12345@12345.com'
7. Capture XML Payload sent to CPQ

For example: In XML payload sent to CPQ side, there is a part that is related to the BillTo customer:

<BillTo>
        <CompanyName>Test</CompanyName>
        <AddressLine1/>
        <AddressLine2>Test address</AddressLine2>
        <City>Test City</City>
        <State>Test State</State>
        <Country>XX</Country>
        <Phone/>
        <Fax/>
        <Email>firstname.lastname@company.com</Email>
        <CustomerCode>12345</CustomerCode>
        <CrmAccountId>12345</CrmAccountId>

</BillTo>

Cause

CPQ System has three options to evaluate Customer info:

  • Evaluate customer by customer code (executing incase customer code has value in XML payload)
  • Evaluate customer by CRM account id (executing incase CRM account id has value in XML payload)
  • Try to get customers by a unique combination of customer details (first name, last name, company name, and address line 1)

When customers are sending customer code and CRM account id as well, the CPQ system will try to find customer by customer code.

Resolution

  • There is a setting in the backend called "C4C_Customer_lookup_by_customerCode".
  • Purpose of this parameter is to enable search by customer code.
  • In case when this parameter is set to FALSE, system will try to find customer using unique combination of customer details mentioned above (point#3).
  • Recommendation for clients is to set C4C_Customer_lookup_by_customerCode to TRUE (contact CPQ Support Team by raising an case) and in that way they will have a consistent behavior (email will not change after they re-open quote).

See Also

3300146 - How to contact SAP CPQ Support team?

Keywords

Email address changed, Customer information changed in CPQ & C4C, Inconsistent customer info, CPQ, C4C, Email issue, CRM account id, customer code , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions