SAP Knowledge Base Article - Public

3353324 - Unable to Access Contact Email Field in SDK or Webservice

Symptom

You are replicating data in Business Communication group and want to update the contact field. However, you are unable to access the field in SDK or Webservice.

Environment

SAP Business ByDesign 

Cause

The field is found on the relationship information, and it is not the email of the "private address" of the Business Partner.

Resolution

The required field contact email is available both in SDK and in the web service.

PATH to field in SDK:

BUSINESS_PARTNER_RELATIONSHIP -> CONTACT_PERSON -> CONTACT_PERSON_WADDR_INF -> ContactPersonWorkplaceAddress.ROOT -> ContactPersonWorkplaceAddress.EMAIL

Web Service on message node:

IsContactPersonForRelationship

Keywords

KBA , AP-BP-BPT , Business Partner Template , Problem

Product

SAP Business ByDesign all versions