Symptom
When accessing the Reports View in the Customer Invoicing Work Center, the report Invoice Volume is duplicated in the Reports View.
Both reports are browser-based type.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Customer Invoicing Work Center.
- Go to Reports View.
- Scroll down to the Report Category: Sales and Marketing - Customer Invoicing section.
- In both Invoice Volume reports, hover the mouse over the graphic Icon in the report type column.
Both Invoice Volume reports are displayed as browser-based type.
Cause
- Go to Business Analytics Work Center
- Go to Design Reports View.
- In the search field, Search for Invoice Volume.
Two Invoice Volume reports are displayed in the UI.
Both have different IDs and different Report Types, the following information is showned :
Invoice Volume report:
ID: CRMCIVIB_Q0001
Report type: browser-based type
Invoice Volume report:
ID: CRMCIVIB_MQ0001
Report type: Mobile Type
The Invoice Volume report CRMCIVIB_MQ0001 is displayed with Report type as browser-based type in the Customer Invoicing.
Summarizing:
In Business Analytics Work Center:
Invoice Volume - CRMCIVIB_MQ0001 - Mobile Based Type
Invoice Volume - CRMCIVIB_Q0001 - Browser Based Type
In Customer Invoicing Work Center Work Center:
Invoice Volume - CRMCIVIB_MQ0001 - Browser Based Type
Invoice Volume - CRMCIVIB_Q0001 - Browser Based Type
The report CRMCIVIB_MQ0001 is displayed as Browser Based Type in the Customer Invoicing Work Center due to changes performed by the development side in the version 1811 of the mobile app performed in 1902 release.
Resolution
This a know issue from SAP Support side and no definitive solution has been implemented yet to avoid the report CRMCIVIB_MQ0001 from being displayed as Browser Based Type in the Customer Invoicing Work center.
As workaround for this scenario there are two available options:
If you do not require/use the CRMCIVIB_MQ0001 for your business needs:
- Go to Business Analytics Work Center.
- Go to Design Reports View.
- In the search field, Search for the report ID CRMCIVIB_MQ0001.
- Filter for Assigned.
- In the Column Assign, unselect all checkboxes that are related to the Customer invoicing Work Center.
- Select Save.
The CRMCIVIB_MQ0001 report will no longer be displayed in the Customer Invoicing Work Center
If you do require/use the CRMCIVIB_MQ0001 for your business needs:
- Go to Customer Invoicing Work Center.
- Go to Reports View.
- Select the Invoice Volume report that requires to be used in the Work Center (CRMCIVIB_Q0001).
- Select the Priority Button.
- Select Mark as Priority.
A exclamation icon will appear in the Priority column of the selected report, this can be used to identify the correct Browser Based Type (CRMCIVIB_Q0001) to be used.
In Addition, for this workaround the user requires to have the priority column available in the Reports: List table of the Customer Invoicing Work Center.
Note: This configuration is not applied to all users, each user who make use of the report (CRMCIVIB_Q0001) in the Customer Invoicing Work Center, needs to perform the above steps once for the exclamation icon to appear in the UI.
Keywords
Invoice volume, volume, report, CRMCIVIB_Q0001, browser based type, CRMCIVIB_MQ0001, mobile based type, moblie type, duplicated report, duplicated, reports view , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , AP-CI-CI , Customer Invoice , How To