SAP Knowledge Base Article - Public

3353650 - Latest KB is not getting activated in CPQ

Symptom

Synced a new product version with Knowledge Base but the previous version stays active.

Environment

SAP SALES CLOUD CPQ integrated with CPS.

Reproducing the Issue

  1. Sync a KB;
  2. Check the product version;
  3. It is visible that previous version is active.

Cause

When a sync is performed and a new build is created for the product, changing an older build and syncing it maintains the build version. If the Effective Date for both builds are the same, system considers the higher build version (meaning, if you have build 1 and 2 in the same date, it will take version 2).

Resolution

Change the Effective Date of the wanted build to a more recent date.

Keywords

CPQ, CPS, KB, Build, Effective Date, Active , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ 2023