Symptom
- You are using Custom Logic Tracing app.
- You want to trace a custom logic that is triggered when using an API.
- You are using a communication user to launch the API.
- You are getting message "Either this method does not have any parameters or an error occurred in the method call" in the Custom Logic Tracing app.
Environment
S/4HANA Cloud
Reproducing the Issue
- Start a trace with Custom Logic Tracing app
- Launch the API with communication user
- Stop the trace in Custom Logic Tracing app
- Access the trace and select an entry
- It shows "Either this method does not have any parameters or an error occurred in the method call"
Cause
The tracing of the parameter values supplied to a Custom Logic implementation will only work successfully if the logic is invoked with a business user(CB-user), but not when it is invoked with a communication user(CC-user).
Resolution
2-System Landscape:
Unfortunately there is currently no workaround for this problem as the parameter value tracing functionality internally relies on prerequisites which can only be met by business users.
3-System Landscape:
With the availability of Developer Extensibility for S/4HANA Cloud, it's possible to debug key user logic via the ABAP Development Tools (ADT).
For more information, please check Key User Debugging
See Also
Keywords
custom logic tracing, custom logic, trace, key user, communication user, api , KBA , BC-SRV-APS-EXT-BL , Custom Business Logic , Problem