Symptom
Customer selection during Quote creation on CPQ-C4C integration is not searching by customer code.
Environment
SAP Sales Cloud CPQ integrated with SAP Cloud for Customer
Reproducing the Issue
- Create a Quote in C4C;
- Fill Customer information;
- Save;
- On CPQ Developer Console it can be seen that Customer information is being queried by Name, Last Name and other information, instead of being queried by Customer Code.
Cause
Backend parameter is not set to True.
Resolution
There is a backend parameter, controlled by SAP CPQ Support team that changes the behavior of the lookup on Quote Creation.
If it is required to Customer be searched by Customer Code, support team should be engaged requesting the change.
When parameter is set to True, if Bill To and End User customers have the same customer Id then End User customer will be updated with Bill To customer values, and vice versa. Meaning they will be the same.
Keywords
Customer, Customer Code, Bill To, C4C, Cloud for Customer, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed