SAP Knowledge Base Article - Public

3354642 - When submitting an E-Verify Case receiving an error that says "An internal error occured while submitting the case." - Onboarding

Symptom

When submitting an E-Verify Case following error is received "An internal error occurred while submitting the case. Please contact Product Support to resolve the issue."

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  • Click on the Complete E-Verify: Create and Submit card
  • Select any one candidate to complete E-Verify step
  • When clicked on it following error is received: 
  • "An internal error occurred while submitting the case. Please contact Product Support to resolve the issue."

Cause

Cause 1: When checked in Manage Data for Compliance configuration object, there are two entries for the groupId US_EVERIFY and one of them does not have the everifyEnvironment value set and is null (No Selection) which is causing this issue.

Cause 2: E-Verify Outage

Resolution

Solution 1: To fix the issue, please delete the current configuration and reconfigure the E-Verify configuration in compliance settings page. 

Solution 2: Confirm Everify DC outage or retry after a day.

Keywords

E-Verify, everify, everify outage, An internal error occurred while submitting the case. Please contact Product Support to resolve the issue, Onboarding, OBX, candidate, onboardee , KBA , LOD-SF-OBX-EVF , Everify , Problem

Product

SAP SuccessFactors Onboarding 2305