Symptom
When submitting an E-Verify Case, an error is received "An internal error occurred while submitting the case. Please contact Product Support to resolve the issue."
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to Onboarding Dashboard
- Click on the Complete E-Verify: Create and Submit (or even from the homepage card of the responsible group)
- When opened, an error is received: "An internal error occurred while submitting the case. Please contact Product Support to resolve the issue."
Cause
- Cause 1: When checked in Manage Data for Compliance configuration object, there are two entries for the groupId US_EVERIFY and one of them does not have the everifyEnvironment value set and is null (No Selection) which is causing this issue.
- Cause 2: E-Verify Outage to such Data Centers
- Cause 3: There was a temporary issue with Mock Service.
Resolution
- Solution 1: To fix the issue, please delete the current configuration and reconfigure again. Ensure that the fields below has value and populated:
- ruleToSelectEverify
- everifyEnvironment
- country
- enabled should be set to 'Yes'
- ruleToEnableForm
- ruleToEnableCorpRep
- Once done, retrigger perform odata refresh and trigger again the Onboarding Compliance Metadata Sync Job
- Solution 2: Confirm Everify DC outage or retry after a day.
- Solution 3: If above solutions doesn't work. Please raise a support ticket.
Support engineers, please see internal note.
See Also
3376044 - E-Verify status synchronization job PROVISIONING_ONBOARDING_2_EVERIFY_STATUS_SYNC_JOB failing
Keywords
E-Verify, everify, everify outage, An internal error occurred while submitting the case. Please contact Product Support to resolve the issue, Onboarding, OBX, candidate, onboardee , KBA , LOD-SF-OBX-EVF , Everify , Problem
Product
SAP SuccessFactors Onboarding all versions