SAP Knowledge Base Article - Public

3354724 - Business user does not exist; Check Tracing Options

Symptom

You have enabled debugging for a specific user on SAP Cloud Applications Studio but the below error comes up:

  • Business user _THIS_USER does not exist; Check Tracing Options (where _THIS_USER is the user ID)

Environment

  • SAP Cloud Applications Studio
  • SAP Cloud for Customer
  • SAP Business ByDesign

Reproducing the Issue

  1. On the Studio, choose Administration > Options and Settings.
  2. On the navigation pane of the Options dialog box, click on SAP.
  3. Then click on the Debugging and Tracing tab.
  4. Input the user ID on "Debugging and tracing: Enable for business user" and check in the box.

Cause

Either the user ID provided is wrong or the user provided is a technical user.

Resolution

Technical users are different than business users and they can only be debugged with after raising an incident to SAP in order for the technical user be temporarily changed to a dialog user.

See Also

SAP Cloud Applications Studio help portal:
https://help.sap.com/docs/SAP_CLOUD_APPLICATIONS_STUDIO/cbcebe3cfb1647a8b0322c18dbb0b481/72eb311b73e21014a15f99c70eec4f5e.html?locale=en-US

Keywords

PDI, SDK, debug, business, user, technical, does, not, exist, Check, Tracing, Options , KBA , AP-RC-BDS-DBG , ByDesign Studio Debugging , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions