SAP Knowledge Base Article - Public

3354827 - What's the logic for "Hours Missing" in the Manage My Timesheet app?

Symptom

In the app Manage My Timesheet, the user observes there are "Hours Missing" that are being displayed.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Search for the app Manage My Timesheet.
  2. Observe the hours missing within the application.

Cause

The Missing Hours data shown in the app Manage My Timesheet, considers all the tasks that an employee has recorded time for.

Resolution

Prerequisites:

  1. Availability Data (Target Hours that user has to be maintained for the Day).
  2. Timesheet Data (Recorded Hours that user recorded their real working hours for the Day)
  3. Duration which limit the past days for Missing Hours' calculation (This is in the configuration "Maintain Data Entry Profiles" for Missing Days - Default is 60 Days)
    The user can also configure the Missing Days by themself.
    Note: Current day hours are not considered for the Missing Hours.

Calculation is done as follows: 

  1. Duration days for calculating the missing hours is (Current date – 1 ) - Past 60 days or the configured missing days.
  2. During the duration, if Recorded Hours is less than Target Hours then it is considered as Missing Day.
    Missing Hours for that day = Target Hours - Recorded Hours.
  3. Current logic calculates and sums up the number of Missing Hours for each day.
    Finally, the total missing hours are shown within the app.

In case the user wants to check the Target Hours and Recorded Hours:

  1. Target Hours: Can be checked from CDS view I_TIMEOVERVIEWBYWRKAGRMTANDDTE.
  2. Recorded Hours: Can be checked from CDS view I_TIMESHEETRECORD.

See Also

Manage My Timesheet

Keywords

Manage My Timesheet, Hours Missing, missing hours, missing day, missing, hour, calculation, I_TIMEOVERVIEWBYWRKAGRMTANDDTE, I_TIMESHEETRECORD , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , How To

Product

SAP S/4HANA Cloud Public Edition all versions