Symptom
Forgot password email is not being sent to candidates after they click on "Forgot password" button.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Candidate access login page
- Click on "Forgot Password?" button
- Message of "Please check the associate email..." pops up
- No email is received by candidate OR they receive it, but with "404 error" once accessing it.
Cause
Cause 1: Due to how the login method is set. Instance may have partial login method setup. If login method is blank, which is equal to SSO (because customer enabled SSO and partial SSO) that’s why this user can't log in with password.
Cause 2: Special characters are being used instead of the [[PasswordResetUrl]] token. Example: Setting passwordResetUrl as 'link', but the text is set as '%5b%5bPasswordResetUrl%5d%5d'. It should instead be '[[PasswordResetUrl]]'.
Resolution
Cause 1: Update this user’s login method to Password. Follow this KBA to setup login method to PWD: 2877392 - Users are not able to login into SAP SuccessFactors - SAP ONE Support Launchpad
Cause 2: The special character, as example '%5d' is not being recognized. Correct it via Manage Data > EmailTemplate > please ensure that the [[PasswordResetUrl]] token is leveraged WITHOUT any artifacts/special characters.
See Also
Keywords
forgot, forgotten, reset, password, button, email, sent, send, receive, candidate, can, cannot, able, change, pwd, issue, login, log in, [[PasswordResetUrl]], token , KBA , LOD-SF-OBX-EML , Notifications , Problem
SAP Knowledge Base Article - Public