SAP Knowledge Base Article - Public

3355414 - Unexpected sequence of change documents when using CRM_SOCM_SERVICE_REPORT

Symptom

  • You are using CRM_SOCM_SERVICE_REPORT to handle your status changes.
  • These status changes could imply the triggering of an import action.
  • Therefore, import order could be relevant.
  • You introduce the documents on desired sequence expecting status changes are handled in that order.
  • The sequence is not respected.

Environment

SAP Solution Manager 7.2

Reproducing the Issue

  • Access CRM_SOCM_SERVICE_REPORT screen.
  • Introduce several documents on a specific sequence.
  • You execute the report.
  • Documents are handled in a non-expected order.

Cause

 The report CRM_SOCM_SERVICE_REPORT is not designed to handle import order of changes. This is documented in online help.

If you want to set multiple change documents to the next status (for example, from Authorized for Production to Imported into Production), execute the batch job CRM_SOCM_SERVICE_REPORT. To set all change documents assigned to a change cycle to the next status, specify the change cycle ID. You can also specify other selection criteria. For example, you can select the urgent changes as the transaction type and specify a change cycle ID to set all urgent changes of the change cycle to the next status. You can also use this report to import all changes at a scheduled time, into the follow-on systems.

Caution: Using this report for a batch import of multiple documents may lead to issues:

  • The dependencies of different change documents are not foreseeable. As a result, the system cannot process the import order automatically.

  • If multiple imports are triggered simultaneously, the program might be impacted due to interferences.

Resolution

This is standard and expected behavior.

You can either develop your own report here, or you have to run CRM_SOCM_SERVICE_REPORT for multiple times in sequential - each time you need to give the change ID you want to import so that the order is handled by your execution.

See Also

2285580 - CRM_SOCM_SERVICE_REPORT does not change status [VIDEO]

Keywords

CRM_SOCM_SERVICE_REPORT, wrong, import, order, sequence, dependency, Change Request Management, SolMan  , KBA , SV-SMG-CM , Change Request Management , How To

Product

SAP Business ByDesign all versions