SAP Knowledge Base Article - Public

3355484 - Home Address portlet keeps loading in employee profile of a user.

Symptom

When we access the employee profile and scroll down to the home address section, the portlet keeps loading.

Environment

Successfactors Employee Profile
SuccessFactors Employee Central

  

Reproducing the Issue

1. Go to user profile
2. Scroll down to Home Address
3. The portlet keeps loading

Cause

addressType picklist not found java.lang.IllegalStateException: addressType picklist not found at com.successfactors

The system is unable to find the addressType picklist.

Resolution

If this picklist is NOT used in any MDF objects, please do this work-around -only if that is confirmed.

Please edit the picklist header object with some change to external code like addressType1 and save

Edit again back to the original addressType. This will reset the legacy picklist ID to addressType.

Keywords

addressType picklist not found java.lang.IllegalStateException: addressType picklist not found at com.successfactors, loading, error, home address , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , Problem

Product

SAP SuccessFactors HXM Core 2305