SAP Knowledge Base Article - Public

3355536 - Not all possible options are shown in dropdown list of attribute

Symptom

The dropdown attribute fails to display all available options even when manually typing the desired value.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Include an attribute in the product with an Autocomplete type, sourced from a custom table;
  2. Navigate to the Catalog and proceed to configure the product;
  3. Verify if all the attribute's values are accessible within the dropdown list.

Cause

The 2305 release has introduced a parameter for Attributes sourced from Custom tables named "Number of autocomplete results for attribute", which defines how many suggestions are displayed to users when they enter a value for autocomplete attributes.

Resolution

In the Setup > General > Application Parameters, you can modify the range for this parameter. The default number is 10. You can enter a number within the range 10-100 and it is available in both Quote 1.0 and Quote 2.0.

See Also

Application Parameters - https://help.sap.com/docs/SAP_CPQ/884885f05e6b4c8082254d4d9d63f19b/a364eff271a542c6b7a55dba773ce78d.html?version=latest 

Keywords

parameter, range, attribute, dropdown, missing, values, product, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To

Product

SAP CPQ 2023