SAP Knowledge Base Article - Public

3355641 - "You do not have permission to edit the value. Please contact your system administrator." error while saving National ID for Colombia - Employee Central

Symptom

As per Implementation Guide for Colombia: Identity - Colombia | SAP Help Portal, system alows from 6 to 10 digits for Cédula de Ciudadania, although when inserting less than 10 characters system displays the error "You do not have permission to edit the value. Please contact your system administrator."

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Configure National ID for Colombia as per KBAs 2526193 - How to Create or Edit National ID Card formats in BCUI, 2520407 - Changes to National ID format for Colombia and Implementation Guide Identity - Colombia | SAP Help Portal;
  2. Go to Employee Profile;
  3. Scroll down to National ID Information > click either on Edit or Add (same behavior is observed);
  4. In Country, choose Colombia and in National ID Card Type: Cédula de Ciudadanía;
  5. In National ID, insert a "Cédula de Ciudadania" with 6 to 9 digits and choose Yes or No in "Is Primary" (according to your requirement);
  6. Hit Save;
  7. Error "You do not have permission to edit the value. Please contact your system administrator." is displayed.

Cause

An OnChange rule is configured to trigger in National ID context.

Resolution

This matter will have a long term solution which has not a fix date planned yet. In the meantime, please follow one of the workarounds below to meet your requirements:

  • Set the rule as OnSave rule instead of OnChange rule;
  • Set one National ID for each required length.

See Also

Keywords

WEF-123628, national id, colombia, You do not have permission to edit the value. Please contact your system administrator, error, successfactors, employee central, employee profile , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , Known Error

Product

SAP SuccessFactors HXM Suite all versions