SAP Knowledge Base Article - Public

3356065 - Custom Indicator Extension Field Isn't Available in the Outbound Payload while Set as False

Symptom

You have a custom indicator extension field set as false in the business object and, while requesting external pricing, the field is not available in the outbound payload.

Environment

SAP Cloud for Customer

Reproducing the Issue

The business object used in the following example is Sales Quote and requesting external pricing, but can refer other transactional data, such as Orders and Opportunities.

  1. Go to Sales WC
  2. Go to Sales Quote View
  3. Search for Quote ID 123 and open it (where 123 means Quote ID number).
  4. In the Quote Header see the custom indicator field set as "No".
  5. Trigger the Request External pricing.
  6. Go to the Administrator work center.
  7. Go to the General Setting work center view.
  8. Open the Web Service Message Monitoring under System Administration
  9. Select query All
  10. Search for outbound web service message triggered.

There is no custom field in the outbound payload.

Cause

Extended XML handling is activated for the simulation API to reduce the payload size. This means that only non-initial extension fields are included. 

Resolution

In order to resolve the issue, the customer can use the node function "mapWithDefault" in CPI to handle the case that custom indicator field set as false.

For CPI customization, you can refer the SAP Blog Post Extending standard integration flow to support Customer extensions.

Keywords

Custom field; extension field; payload, outbound; sales; quote. order. opportunity; pricing; external; indicator. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications 2305