Symptom
Incoming Messages To Cloud For Customer Fails With Error "Inbound message processing failed"
Environment
Cloud For Customer Integration with S/4HANA
Cloud For Customer Integration with S/4HANA Cloud
Reproducing the Issue
- Go to Administrator
- Go to General Settings
- Go to Webservice message monitor and check the failed message with service interface "MaterialReplicationInitiatedByExternalIn"
- View Payload to find the data sent to C4C.
</QuantityCharacteristic>
<QuantityCharacteristic actionCode="04">
<Quantity unitCode="XXX">1</Quantity>
<CharacteristicQuantityTypeCode>XXX</CharacteristicQuantityTypeCode>
<CharacteristicQuantity xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:nil="true"/>
</QuantityCharacteristic>
Cause
Error is due to empty CharacteristicQuantity sent under QuantityCharacteristic nodes to C4C
Resolution
We have updated the message mapping to handle such information and drop those nodes without reaching C4C. Please ensure you are using the latest message mapping in case of PI or iflows in case of CPI
Keywords
"MaterialReplicationInitiatedByExternalIn" ; "Inbound message processing failed" , KBA , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , Known Error