Symptom
Incoming messages to Cloud for Customer fails with error "Inbound message processing failed".
Environment
- Cloud For Customer
- S/4HANA Cloud
- S/4HANA
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Settings work view.
- Go to Webservice message monitoring.
- Check the failed message with service interface "MaterialReplicationInitiatedByExternalIn".
- View Payload to find the data sent to C4C:
</QuantityCharacteristic>
<QuantityCharacteristic actionCode="04">
<Quantity unitCode="XXX">1</Quantity>
<CharacteristicQuantityTypeCode>XXX</CharacteristicQuantityTypeCode>
<CharacteristicQuantity xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:nil="true"/>
</QuantityCharacteristic>
Cause
Error is due to empty CharacteristicQuantity sent under QuantityCharacteristic nodes to C4C.
SAP has updated the message mapping to handle such information and drop those nodes without reaching C4C.
Resolution
Therefore, please ensure you are using the latest message mapping in case of PI or iflows in case of CPI
Keywords
"MaterialReplicationInitiatedByExternalIn" ; "Inbound message processing failed", C4C, Integration, S/4HANA, S/4HANA Cloud, Webservice message monitoring , KBA , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , Known Error