Symptom
The sales orders are not displaying/updating the notes' text in C4C despite being filled in the incoming payload during replication.
Environment
- SAP Cloud for Customer
Reproducing the Issue
- Identify the affected sales order number
- Access the Admin -> Webservice Message Monitoring
- Locate the associated web service message under the service interface CustomerOrderReplicationIn
- Open the payload of the web service message
- Find and navigate to the <TextCollection> field
- Verify that the <TextContent> field is filled
- Check if the notes information is missing in the sales order
Cause
The languageCode in the TextContent field is not being populated.
Resolution
Ensure that the external system maintains and sends a valid languageCode when replicating the sales order notes.
See Also
- 3018655 - Activity or Material Notes Replicated from External System are not being updated in C4C
- Text Collection Integration in Cloud for Customer
Keywords
TextCollection, TextContent, languageCode, CustomerOrderReplicationIn, CustomerQuoteProcessingSalesOrderRequestOut , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , Problem
Product
SAP Cloud for Customer core applications all versions