SAP Knowledge Base Article - Public

3356733 - Email Address is not appearing in Personal Data Collection - Onboarding

Symptom

  • Under Email Information section in the Personal Data Collection step, there is no data coming, although Email address is being correctly passed from RCM.
  • Once user restarts the Onboarding for affected candidate, the Email Information data appears again in PDC.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Candidate starts the Personal Data Collection
  2. There is no email address under Email Information section
  3. Once checking the data coming from RCM, email address are correctly mapped.

Cause

onChange rule is enabled for Onboarding context.

Resolution

onChange rules are not supposed to be enabled to Onboarding, once these kind of errors could happen. Disable it only for Onboarding context:

  1. Open Manage Business Configuration
  2. Click on "emailInfo" section
  3. In the first field under Identifier > "email address" click in "Details" 
  4. Scroll Down and check the Trigger Rules for Event Type "onChange" and Rule as example: "EC_EmailInfo_EmailAddressValidation.."
  5. Open "Details" for respected rule
  6. In Onboarding field change it from "Yes" to "No".

It will be required to restart the Onboarding for the affected candidates.

Keywords

email, address, not, passing, coming, appearing, no, data, blank, empty, value, email, information, section, field, under, onboarding, PDC, personal, data, collection, step, RCM, candidate, available, onboardee , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem

Product

SAP SuccessFactors Onboarding all versions