Symptom
You are trying to perform an Upsert, and is receiving an error equal or similar to the one below:
"ChangeSet index 1 - User XXX doesn't have the 'Employee Central HRIS odata API' admin edit permission! "
Environment
-
SAP SuccessFactors HCM Suite
- SuccessFactors OData API
Cause
API User is lacking Admin-Mode permission.
Resolution
Please grant the API user the Admin-Mode permissions, as they are necessary for API Upserts.
Please find below the Guide explanation about this:
Authorization/Action |
In Permission..., choose |
Additional Info |
---|---|---|
User Mode (Query Only) |
|
You can grant view permissions at entity and field levels. Upsert, that is import information in your instance, is only available in Admin Mode. |
Admin Mode (Query) | Administrator Permissions Employee Central API Employee Central HRIS OData API (read-only) |
This permission allows users to query all HRIS objects and overrides entity-level and field-level view permissions. If you want to upsert HRIS objects, you need to have the Admin Mode (Upsert) authorization. |
Admin Mode (Upsert) | Administrator Permissions Employee Central API Employee Central HRIS OData API (editable) |
This permission allows users to upsert all HRIS objects and overrides entity-level and field-level edit permissions. If you want to query HRIS objects, you need to have the entity-level or field-level view permissions, or have the Admin Mode (Query) authorization. |
See Also
Keywords
unable to perform upsert,upserts, doesn't have the 'Employee Central HRIS odata API' admin edit permission, Employee Central HRIS odata API, UPSERT, update, insert. , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem