SAP Knowledge Base Article - Public

3357198 - Advanced Search in Activity List Showing Wrong Results when Setting Filter to Exclude

Symptom

When using the Advanced Search option in Activity List, the filter is set to exclude an activity type (example: Instructional). However, the search results show all Instructional activity types.

Environment

  • SAP Business ByDesign
  • SAP Cloud for Customer

Reproducing the Issue

In Business ByDesign

  1. Go to Business Configuration work center
  2. Navigate to Implementation Projects view
  3. Mark the relevant project and Open Activity List
  4. Select the dropdown to be All Activities
  5. Click on the Open Advance Filter button
  6. Under Activity Type, click on the More Filters button
  7. Tick the box But exclude
  8. Set the Options as Equals to and choose your value (example: Instructional)
  9. Click OK and press Go

 

In Cloud for Customer

  1. Go to Business Configuration work center
  2. Navigate to Implementation Projects view
  3. Mark the relevant project and Open Activity List
  4. Select the dropdown to be All Activities
  5. Click on the Advance Search button
  6. Under Activity Type, click on the More Options button
  7. Open the Exclude section and set the Condition to Equals to, and enter in the value (example: Instructional)
  8. Click OK and press Go

 

In this example, the search results for excluding Instructional activities shown only Instructional activities, the opposite of what was searched for.

Cause

This is a current system behaviour in the filter search. The query entered is considering excluded values as include, which is resulting in an incorrect search list.

Resolution

This has been added to the product backlog and it will be fixed in upcoming releases.

Keywords

Advance Search, Advance Filter, Filter, Activity List, Exclude, Include , KBA , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer core applications all versions