SAP Knowledge Base Article - Public

3357479 - User cannot receive Learning Expiration/Overdue Notification as per the APM setting

Symptom

User didn't receive Learning Overdue Notification or Learning Expiration Notification even they have overdue items on Learning Plan.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

1. On Learning Expiration Notification APM screen, set Threshold (e.g. 60 days) and Reminder Period (e.g. 1 day)

2. Propagate the setting to all existing items

3. Run the APM

4. User who has overdue course didn't receive notification or received notification but not all items that meet the criteria are listed. 

Cause

APM was executed before and has updated the Reminder Date to a future date.

Resolution

Please check User Learning Plan Audit report, filter the affected User ID and Item ID.

There will be one or multiple records of which the 'Last Updated By' is 'APM_TRNGEXPIRE' and the latest Reminder Date is a future date.

In this case, even user propagated the new Threshold and Reminder Period to all existing items, the Reminder Date won't be changed.

As a result, APM won't pick this record because the Reminder Date is still in future.

Only after the current Reminder Date, user will start to receive notification as per the new Reminder Period.

 

 

Keywords

Learning Expiration Notification, Learning Overdue Notification, Item Reminder mail , KBA , LOD-SF-LMS-NOT , Notifications , Problem

Product

SAP SuccessFactors Learning all versions