SAP Knowledge Base Article - Public

3357493 - Mobile Logins not showing in Login Report

Symptom

  • Accessing the SuccessFactors Mobile App each time does not trigger a log in in the user login report.
  • When generating the Login Data report for a user, it appears that the user is missing a login data from a specific date only even though they have login data on other dates. 

Environment

SAP SuccessFactors HCM Core

Reproducing the Issue

  1. Let a user login on SuccessFactors via Mobile App that already went through the activation process
  2. On a web browser, login to SuccessFactors and navigate to Reports > Reports Center >Table Report (formerly called Adhoc Reports).
  3. Select Create New Report. Navigate to Login Data under the option of Report Definition Type.
  4. Configure the columns and filters. 
  5. On the data of a specific user, no login data can be seen on a specific date where they logged in via their mobile device. 

Cause

Once the app is activated, subsequent access of the app does not count as login and therefore will not show on the login report. 

Resolution

When a user logs in via a mobile device, the authentication process may differ from logging in via a browser on a laptop. For instance, if the user logged in on January 1st using their mobile device, this initial login would be recorded in the audit report. But subsequent logins in the next day (ex. January 2nd) from the same device will not trigger a new authentication process due to the persistence of the login validity on the mobile device, so those logins will not be recorded in the audit report.

See Also

Keywords

Login Data, audit log, login report, report, inactive, table reports, KBA, LOD-SF-PLT-LPG, Log In Page Issues (Non SSO), LOD-SF-PLT, Platform Foundational Capabilities, How To, LOD-SF-MOB , KBA , LOD-SF-PLT-MOB , Mobile Issues , LOD-SF-PLT-AUDR , Request Audit Report (Not Change Audit) , Problem

Product

SAP SuccessFactors HCM Core all versions