SAP Knowledge Base Article - Public

3357651 - Unable To Save Formatted Text In Visit Notes

Symptom

The user cannot copy and paste the paragraphs from the Word document to the Notes in Visits.

Environment

  • SAP Cloud for Customer

Reproducing the Issue

  1. Go to Visits Workcenter
  2. Search for Visit ID XXXX
  3. Click on Open Object Details
  4. Under Overview tab, navigate to the Notes field enter the copied text from the word document
  5. Click on Save

The below error occurs:

  • Save failed
  • Invalid value "%background:white" for attribute style of tag <span>
  • Invalid value "font-variant-ligatures:normalfont-variant-caps:nor" for attribute style of tag <span>
  • Invalid value "%" for attribute style of tag <span>
  • Invalid value "font-variant-ligatures:normalfont-variant-caps:nor" for attribute style of tag <br>
  • Invalid value "background:white" for attribute style of tag <span>
  • Save could not be executed

Cause

When copying text from certain sources, for example, a Word Document, it can contain formatting. Hence, when pasting it into a formatted text field in Notes in Visit, we get the error message.

Resolution

It is always recommended to use the built-in rich text editor of C4C and paste only from pure text apps such as Notepad in order to avoid any issues (such as with form templates and data extraction).

If you paste the text into an area that clears formatting (for example, Notepad) first and copy it from there into the formatted text field, or if you type the text directly into the field, then there are no issues encountered.

See Also

2834551 - Supported Formatting Options in Cloud for Customer

Keywords

Notes, Visit, Formatted text, Rich Text Editor, Notepad , KBA , AP-RC-DOC , Document Centric Application Service , Problem

Product

SAP Cloud for Customer core applications all versions