Symptom
The External Users or an Admin are able to change the email address to another one that already exists in the system, despite the setting selfRegistrationUniqueEmailAddressRequired=true.
Environment
Reproducing the Issue
- Let a user create their external account via LMS Site >
- User select an unique email (selfRegistrationUniqueEmailAddressRequired=true) >
- Issue 1: An admin can change that email to another that already existing in the system
- Issue 2: The user itself can change their own email to another that already existing in the system
Cause
Current system behavior.
Resolution
As per the tests and Product Management confirmation, the system does not currently support an option to enforce uniqueness of email other than on self-registration.
To summarize the scenario, according to the documentation for this setting 'SAP SuccessFactors Learning System Properties in LMS_ADMIN':
We recommend a value of true even though the default value is false to maintain legacy behavior. When you set this to true, you force anyone who self-registers through SAP SuccessFactors Learning to have a unique email address.
This means that the validation happens at the registration time, but not if the users/admins try to change the email address of the user after they are created.
Considering is not a feature currently available, you may want to submit an Enhancement Request for this. Please kindly refer to the KBA 2090228 for further details.
See Also
SAP Help SAP SuccessFactors Learning System Properties in LMS_ADMIN
SAP Help Learning Configuration Procedure
Keywords
External Users, Admin, change the email address, change, email, address, selfRegistrationUniqueEmailAddressRequired, selfRegistrationUniqueEmailAddressRequired=true, unique , KBA , LOD-SF-LMS-EXT , Sites and External Users , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-IAS , LMS IAS Integration for External User , Product Enhancement