Symptom
If you compare the UI versus Odata outcomes, you notice that there are some wrong dates through the system.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the affected BO (let's use Sales as an example)
- Sales Quotes Work Center View.
- Open a Sales Quote ID "201".
- See that, for example, Start Date field is set as May 10th
- If you check this object through Odata: https://my000000.crm.ondemand.com/sap/c4c/odata/v1/c4codataapi/SalesQuoteCollection?ID=201
You notice that the date is set as May 9th.
Cause
OData API response does not consider User Settings for DateTime conversion. That is used only on UI but ultimately it is stored in UTC format.
OData API returns the data with UTC format, it is not changing the data but giving a different representation with required info that the data is in UTC 'with Z' at the last.
Resolution
You can check a time converter tool in order to understand the difference further. You can proceed transforming for the relevant field before use.
You can also access our Influence Portal and suggest a change in this scenario.
See Also
Keywords
Wrong; Date; UI; Odata; Mismatch; Day. , KBA , LOD-CRM-INT-API , OData API (C4C Only) , How To