SAP Knowledge Base Article - Public

3358426 - Declined workflow request in timesheet does not reduce recorded time

Symptom

“Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

  • Declined workflow request in timesheet does not reduce recorded time 
  • When we submit personal hours in timesheet  say 2 hours and if the manager declines the request, the recorded time in timesheet for that day still shows 2 hours instead of 0 hrs post decline of the workflow request

Environment

 SAP SuccessFactors Employee Central - Time Sheet 

Reproducing the Issue

  1. Record Overtime say for 2.29 hours say for 21st July 2023
  2. Submit the Time sheet for Approval
  3. Manager declines the workflow request 
  4. Go to Time sheet for 21st July , where number of hours of overtime recorded still shows 2.29 hours 

Cause

Expected system behaviour 

Resolution

  1. The employee would need to make correction to working hours in the time sheet to correct hours already recorded
  2. Approve or Decline of Time sheet workflow request by the manager would not change the number of hours already recorded by the employee

See Also

workflow,approver page, employee time sheet, timesheet,recording, valuation,manage workflow requests,tms,time, overtime ,cancel

Keywords

KBA , LOD-SF-EC-TMS , Time Sheet , LOD-SF-TTR-TMS , Time Sheet , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors Time Tracking all versions