Symptom
You are using Automated Supplier Invoice Upload bot and the bot is failing with below error,
Call to OData service failed : Check ByDesign credentials
Due to which invoices are moving into the "Failed" folder.
Environment
SAP Business ByDesign
Reproducing the Issue
- Execute the bot
- Check the log file
Cause
There are multiple causes for this issue and they are as follows
1. The windows credentials are not valid. The most common issue is where the account credentials are expired
2. If you are not using the latest version of the Bot.
Resolution
For windows credentials, refer to the Tech Spec documentation for the respective BOT in the BOT Store
For version update of BOT, refer to the KBA
It is worth noting that in some cases the most up-to-date version of the bot may have been uploaded to the store as a separated version (for example, the Supplier Invoice Scanning bot 1R1 has its most updated version as 1R1-CSV Log).
Keywords
latest version, odata, credentials, , KBA , AP-ML-RPA-EXE , ByDesign - Robotics process Automation - Bots Execution , CA-ML-IPA , IPA , Problem