SAP Knowledge Base Article - Public

3358934 - Incorrect Account ID Business Partner Replication from S/4 to C4C

Symptom

Replicating Business Partners from S/4 into C4C using the standard "Business Partner Replication from SAP Business Suite" Upon Account creation in C4C the Account ID is not created using the C4C internal number group.

Environment

SAP Cloud for Customer 

Reproducing the Issue

  1. Replicate a business partner created in S/4 HANA to Cloud for Customer.
  2. Check if the account ID in C4C is the same as the S/4 HANA id for the account.

Cause

When replicating a business partner from external, the ID from S4 will be taken only if:

  1. This ID is not already used by another business partner
  2. This is a Valid ID
  3. There is an external number range existing for this ID.

 

Resolution

If you always want the internal number range to be used as C4C ID then you should not have a valid external number range defined.

To solve this, you can either remove the external number range or make sure that the external number range provided (if required for another integration scenario) does not match the number range used by S4.

Keywords

Business Partner Replication from SAP Business Suite, Cloud for Customer, S/4 HANA, BusinessPartnerReplicationIn, AccountID, external, account, ID, number range , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer core applications 2305