Symptom
The link on the kanban (created using standard query) when clicked navigates to incorrect count.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Create a custom card - Kanban
2. Provide the Business Object (in this case "Tickets"), data set query (any standard query - in this case "All tickets")
3. Provide an attribute (in this case "Status") and add the relevant values to be considered (in this case statuses "Open - working on it" and "Completed"), add the relevant display fields and save.
4. Make the newly created Kanban visible
5. Observe that the link on the kanban holds a given value (in this case "All Tickets (1004)")
6. But on clicking this link it navigates to the ticket view containing a different value (in this case "All Tickets (143309)")
Cause
While creating a Kanban from a standard query the count on the kanban link (1004 in this case) is computed based on the attribute and the values provided for the given Kanban Customization (in this case 631+ 373), but on navigating to the ticket view the query contains data with respect to all the fieds and columns maintained on that view including the attribute set on the kanban and hence results differ (143309)
Kindly note, the kanban is merely a display of data and the computation will only respect the values and attributes maintained at the time of creation of the kanban board and not the actual view data.
Resolution
This is an expected behavior. Custom queries can be created and used during kanban creation to suit different scenarios.
Keywords
Kanban link, incorrect count, Standard query, Kanban Link Navigation , KBA , LOD-CRM-HOM , Home Page , Problem
Product
Attachments
kanban board.png |
kanban board.png |
Kanban creation 1.png |
kanban creation 2.png |
tickets view.png |