Symptom
- The error: "Failed to upload because of an error in the plugin service" happens when consuming the data from universe to SAC even you are able to select the universe objects
- Able to select the universe object into query result when creating the Model against the universe.
- The error only happen when execute the query in SAC.
- In the SAC Agent tomcat log, the error below happens.
SEVERE [http-nio-8080-exec-5] com.sap.fpa.cloud.rest.unx.DSLQuery.null CID[xxxxxxxxx-xxxx-xxx-xx-xxxxxxxxx] TID[xxxxxxxxx-xxxx-xxx-xx-xxxxxxxxx] not ready to serve
Environment
- SAP Analytics Cloud (SAC) (Enterprise) 1.0
- SAC Agent 1.0.377
- SAP BusinessObjects Business Intelligence Platform (BI) 4.2 Support Package 09 (SP09) Patch 13
- Universe
Reproducing the Issue
- Install the Cloud Connect.
- Install the SAC Agent.
- Configure the Cloud Connect.
- Configure the SAC Agent to insert the BI server in the Cloud Connect.
- In SAC, Add a new location from the System/Administration/Data Source Configuration/On-Premise data sources.
- New add connection is working fine.
- Create Connection, SAC->Connection->Add new connection via Acquire Data->SAP Universe.
- Select the objects into the result.
- Execute the query to get the data, failed.
==>The error "Failed to upload because of an error in the plugin service" happens.
Cause
- SAC Agent binding Jar files mismatch with the BI Platform server.
Resolution
Apply the solution by following KBA 3262098 - Post installation instructions for SAP Analytics Cloud Agent and Universes 1.0.355+
See Also
- SAP Analytics Cloud Best Practices and Troubleshooting Community expert page
- SAP Analytics Cloud – Authentication and Data Connectivity openSAP course (free!)
- 2540886 - How to export data from models in SAP Analytics Cloud?
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAC, Universe, BI, 4.2, universe, unable, error, Agent version, jar, refresh, run, execute , KBA , LOD-ANA-AQU-UNV , SAC Acquiring Data Universe , Problem
Product
SAP Analytics Cloud 1.0